Abiword with ODT file support

Abiword is an interesting alternative to LibreOffice. Of course, it has fewer functions and is not a full 1: 1 equivalent, but it also has undeniable advantages, e.g. speed of operation, installation of the word processor itself.

There is a current version of the program in the extra Arch Linux repository which uses gtk3. Unfortunately, at least for me (ArchLabs) it does not work well, i.e. there is a flickering of the program’s working area.

There is an alternative version of the program in AUR repositories – abiword-gtk2, which of course uses gtk2. The flickering problem is gone, but this version is lite version and there is no support for e.g. plugins, including support for LibreOffice odt files.

To build a version with support for odt files, delete the entries in the PKBUILD file:

--disable-builtin-plugins \
--disable-default-plugins \

Instead of these, put an entry:

--enable-plugins="opendocument openwriter openoffice writer filter" \

You can generate a package:

makepkg -Acs

And then install:

sudo pacman -U abiword-gtk2-replace _with _program_version.tar.xz

and there you go!

Leave a Reply

Your email address will not be published. Required fields are marked *